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Introduction to Internet

INTRODUCTION TO INTERNET

The Internet is a collection of computer networks which have a common way of passing material
between them, in effect creating a single world-wide network.  Thus, the Internet is the global
network of networks which use the TCP/IP protocols to interact with other TCP/IP networks via
gateways.

It provides users with electronic mail messaging, remote login, file transfer, network news, the
WWW; and other related services and tools. For academic users this means access to an
enormous range of resources, and much of this material is provided by individual users and
departments at other academic sites around the world. Also, as more and more people have
access to the Internet,  it becomes an increasingly efficient way of making contact with others
working in similar fields.

HISTORY

The Internet was born about 20 years ago, out of an effort to connect together a U.S defence
department network called  ARPAnet and various other radio and satellite networks. The
ARPAnet was an experimental network designed to support military research. The aim was to
build networks that could withstand partial outages and still function. In the ARPAnet model,
communication always occurs between a source and a destination computer.

ARPANET originally connected four universities and enabled scientists to share information
and resources across long distance. ARPANET continued to expand, connecting many more
sites throughout the 1970’s and 1980’s.

Who governs the Internet ?

Inernet is not governed by any particular body. It has no President or Chief Executive. However,
a council of volunteers, called INTERNET ARCHITECTURE BOARD, or the IAB meets
regularly to approve standards and allocate resources, such as addresses. The Internet works
because there are standards and ways for the computer and software application to talk to
each other. This allows computer from different vendors to communicate with each other. It’s
not IBM only, SUN only or the Macintosh - only  network. The IAB are responsible for the
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standards.

Every Internet user has opinion about how  the things ought to be run. Internet users express
their opinions through meetings of the Internet Engineering Task Force (IETF). The IETF is
another volunteer organization. It meets regularly to discuss operational and near-term technical
problem of the Internet. When it considers a problem important enough to merit concern, the
IETF sets up a “Working Group” for further investigation . Any one can attend IETF meetings
and be a working group.

Who Pays for It ?

Every Internet user or corporation pays for its connection to Internet Service Provider for the
access. Therefore, everyone pays for their part. Networks get together and decide how to
connect themselves and fund their interconnections.

INTERNET FOR ONE AND FOR ALL

For Student’s :  A man who yearns for knowledge is always a student. Whether you are five
years old or fifty, if you need any information on any subject it is the network you should check
out first. The net is the largest library that you can be a member of. So, whether you are doing
your geography home work or research on the Bermuda Triangle, you are sure to find more
information on the subject, then you could even handle. Therefore, any student with a PC and
modem should not miss out any information.

For Business Society :  An ordinary man/woman can develop his/her business/profession by
the use of internet for: market survey, products availability, scope and viability, marketing trend
and market size and project implementation etc. Internet has tremendous information on
entrepreneurial – managerial – financial and technological aspects.

Hence, to set up a global office you will have to buy a Web site or Web pages and put your
information  there. You will need to constantly update your information or else users will stop
visiting your site.

For Foreign Trade :  For people dealing in foreign trade, the internet is of further advantage.
Whether you are into imports or exports, internet can reduce your communication costs as
well as act as a direct interface between you and your clients.

For an importer the top two consideration for a deal are, the product and the price. ‘A simple
search across the Web can fetch you more addresses of prospective sources than any directory
you could buy in this world. On top of that, you could e-mail to the company your requirements,
the conditions for the deal and the necessary details immediately and cut down the cost of the
communications as well as the delay involved. In fact, there are high chances that you will get
the response from the opposite side sooner than you could have imagined.

As for an exporter, the greater the exposure the more the business. The net is the media which
tops in this criteria. You don’t even need a web site. A web page which costs around three
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thousand rupees will be sufficient. There are hundreds of web consultants who have set up
shops in India and will eagerly do this task for you.

For Inter Corporate Communications :  The internet facilities such as chat & tools which
could reduce more than half of your communications bill. By simply using E-mail instead of fax
and telex you can cut down the price of your telephone bills by 75%. Along with this you get a
prompt and absolutely secure delivery of message.

The chat facility has the potential to not only reduce the costs of communication but also to
improve its quality.  On a normal phone call a maximum of three callers can talk simultaneously,
but with chat, all your regional offices can have a conference and that too at the cost of local
call.  Just imagine no more of those STD if each of your offices gets an internet connection.

The software development community :  The question that has been repetitively asked is
that if India has one of the best programmers in the world, then why don’t we have an Indian
Software which is a equivalent of Windows98 or JAVA? Why are none of the Indian products
so famous? The reply has always been the lack of money to market. Now at least the Indian
software developers have a platform where they are equivalent to their US counter-parts. They
can market their product easily. The internet is open to all, and anybody may exhibit his/her
products on it.  Apart from being a larger distribution channel, internet also opens new frontiers
for after sales service and up-gradation facilities. An upgrade or a patch can easily be put on
the net and the distribution costs can be reduced dramatically.

For Common Man :  Internet is highly useful  for a common man. Internet will be the future
version of household television or vice-versa. You can get any information on the  net, be it the
news, your favorite recipes or the latest stock quotes. You could daily converse or exchange
messages with your relatives anywhere in the world and get pay only for local calls.
You could choose the best place to spend your vacations and could even make the reservations
in advance from your terminal itself. And if you are one of the privileged ones to own a credit
card, you could even go ahead and make a purchase over the net. The possibilities are endless,
the implications mind boggling. The facilities are just great.

Therefore Internet is widely used for Exchanging electronic mail, Participating in group discussions on
topics of interest, through public news groups, Sharing online information from Universities, books stores,
and libraries, Shopping over the net, Publishing information such as technical or marketing literature and
for Marketing & selling of products online.

HOW THE INTERNET WORKS ?

Sites, Hosts and Addresses:  All the information available on the Internet is located on specific
computers (called “hosts”) at particular sites. Each host had a unique number – the “IP number”,
which the average user doesn’t  need to bother with (IP stands for “Internet Protocol”) – and a
unique name, which functions as its address. That name (often called the “domain name”) is
made up of a number of components (typically 4) separated by periods, as can be seen in the
Internet address of the main UNIX server at CEDTI.

cedtm.stpm.soft.net : Here, cedtm  is the name of the individual server, stpm  the name of the
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site the server is located at, and soft.net  refers to the Network resource provider domain in
which that site is located. With the exception of internet sites in the USA, all Internet address
end with a two letter country code. US addresses have as their final element not a country
code, but a three letter abbreviation indication which network they are on.  The IP number of
cedtm  is 12.3.72.137.

When you wish to send something to or make contact with another Internet site, you will need
to know the Internet address of that other site.

URL’s :  Some Internet applications use what is called a “Uniform Resource Location” (URL) to
locate resources on the Internet. This is in a sense simply a more elaborate form of address,
specifying not only the Internet site name, but also the directory and file in which a resource is
located as well as which method to use when retrieving it. Currently, only the World-wide Web
uses URLs.

Therefore, URL is a  way to locate people, computers, and Internet resources and is used to
identify specific sites and files available on the World Wide Web.
The structure of a URL is:
protocol://server.subdomain.top-level-domain/directory/filename.

Not all URLs will have the directory and filename.
For example:
http://www.lycos.com/welcome.html

Using the Internet requires an understanding of different addressing schemes. People are
identified with electronic mail addresses. Computers are identified with IP addresses and
domain names. Resources and files available through the World Wide Web are identified using
URLs.

THE INTERNET PROTOCOL (IP)

Protocols are the rules that govern how the Internet works.  The Internet Protocol takes care of
addressing, or making sure that the routers know  what to do with the data when it arrives.
Some addressing information goes at the beginning of your message, this information gives
the network enough information to deliver the packet of data.

WHAT IS AN IP ADDRESS ?

An IP address is a unique, numeric identifier used to specify a particular host on a particular
network, and is part of a global, standardized scheme for identifying machines that are connected
to the Internet.

IP addresses consist of four number between 0 and 255, separated by periods, which represent
both the network and the host machine. IP addresses are also referred to as IP numbers and
Internet addresses. The InterNIC, under the authority of the Internet Assigned Numbers Authority
(IANA), allocates the network portions of IP addresses to Internet Service Providers (ISPs):
ISPs are responsible for assigning the host portion of  the IP address to machines within their
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local networks.

If you want to connect to another computer, transferred files to or from another computer, of
send an e-mail message, you first need to know where the other computer is - you first need
the computer’s “address”.

THE DOMAIN NAME SYSTEM STRUCTURE

The DNS is a method of administering names by giving different groups responsibility for
subsets of the names.  Each level in this system is called a domain.  The domains are separated
by periods. For example: cedtm.stpm.soft.net

Thus we see that every on the Internet has both a domain name and an  IP address, and when
you use a domain name, the computers translate that name to the corresponding IP address.
The names of the domain describe organisational or geographic realities.  They indicate what
country the network connection is in,  what kind of organisation owns it,  and further details if
any.

Non Geographic Domains

There are six common top level domain types that are non-geographical  :

.com for commercial organisations, such as netcom.com, apple.com, sun.com etc.

.net for network organisations, such as internic.net

.gov for parts of governments within the US, such as nasa.gov, oklahoma.gov,etc.

.edu for organisations of higher education, such as sjsu.edu, ucsc.edu, mit.edu., etc.

.mil for non classified military networks, such as army.mil, etc.

.int International institutions (e.g. NATO)

.org for organisations that do not otherwise fit the commercial or educational
designation, such as eff.org, farnet.org etc.

Geographic Domains

The geographically based top level domains use two-letter country designations.  For ex, .us
is used for the United States, .ca for Canada, .uk  for the United Kingdom and .in for India.

A domain name always contains two or more components separated by periods, called “dots.”

internic.net
netsol.com
nasa.gov
utexas.edu
reston.va.us

Therefore, the Domain Name System completes the task of matching domain names to IP
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(Internet Protocol) addresses. Domain names, and their corresponding IP addresses, must be
unique. If more than one organization on the Internet had the same domain name, confusion
would occur when the network tried to identify and communicate with the computer within
those organizations.

This system allows  allows Internet users to deal with the more intuitive domain names, rather
than having to remember a series of numbers.

INTERNET CONNECTION OPTIONS

Dedicated and Dial-up Links

There are several ways to connect to the internet.
* Dedicated Internet Access
* PC dial-up access

Dedicated Internet Access

It needs dedicated a phone line connecting your LAN or PC to the Internet 24 Hours a day. A
dedicated Internet access requires substantial initial investment in equipment and a monthly
fee for the use of the line. It varies  with line capacity, and line capacity determines how many
users can connect to internet simultaneously.

PC Dial-up Access

This is the simplest type of connection to Internet. You need a computer modem (attached to a
phone line) and any of the popular telecommunications packages. The user dials-in to an
Internet service provider. Each user has an account on the Internet Services providers host
computer. You ask the host computer to go out onto the Internet to do what you want to be done.
Host providers will send & receiver E-mail, transfer files from a remote internet computer to the
host from where you can then down load to your own computer.

TYPES OF DIALUP CONNECTIONS

If you have computer, some communication software, a telephone line, and a modem, you can
connect to the Internet. The major ways that you can link to the Net using dialup are:

* Host/Terminal connection
* Individual computer TCP/IP Link

HOST/TERMINAL CONNECTION (SHELL ACCOUNTS)

In a host/terminal  connection, your computer acts as if it were a terminal directly connected  to
some Internet host. The program signals your modem to dial and handles the transfer of
characters from your terminal to the host computer and back. Your connection is at one remove:
that is, the host computer is one that is “on the Internet”. Thiois means that when you transfer
file using FTP, for example, the files are transferred to the host. You will then need to download
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the file to your computer using your communications program.

INDIVIDUAL COMPUTER TCP/IP LINK

An individual computer TCP/IP link allows your computer to function as an Internet host. Its
your host running whatever software you elect to run, providing  only the service you have
chosen to provide. These links are called either SLIP (serial link Internet protocol) or PPP
(point to point protocol) links. Both types of links will handle dialup. Both can take advantage of
new software techniques that condense or compress the data being transmitted so that
transferring information takes less time.

MODEM

Hundreds of thousands of users of Internet users make their connection to the Net via a dialup
modem and communication software running on their personal workstation. The purpose of
the modem (modulator demodulator) is to translate the digital signals that computers use to
store and transmit information into the analog signals that telephone lines (or radio data systems)
use to transmit information.

A network that allows dial-in access provides one modem at its end, while a user who dials in
provides the other. These modems have to be compatible to be able to communicate.

COMMUNICATION SOFTWARE

Communication software (sometimes called as “terminal emulation software”) enables your
computer to communicate with another computer. Communications software is commonly used
in combination with modem. The software offers a you to give commands to the modem, to dial
the other computer’s modem, and then to issue commands and receive responses from the
remote computer. There are many different packages available today. They fall into two
categories: :“terminal” (used for accessing most host/shell account systems) and “TCP/IP based”
(which let your computer become a host on the Internet). The “dumb terminal” packages like
ProComm Plus for DOS/Windows  use your computer as a keyboard and display attached to
the remote machine. “TCP/IP” based communication packages establish your computer as a
workstation on a network.

TYPES OF INTERNET APPLICATIONS

There are three main types of Internet applications :
1. Those based on sending and receiving mail messages
2. Those based on logging in to a remote Internet host.
3. Those based on browsing.

To some extent these are interchangeable, as Internet resources are increasingly available by
more than one method. But from the user’s point of view they are used in very different ways.

ELECTRONIC MAIL
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Electronic Mail (e-mail) is a system whereby a computer user can exchange messages with
other computer users or group of users via a communications network.

Advantages:

* Delays of getting a physical document from one person to another are eliminated.
* The receivers need not be present on site when mail is sent to him.
* Mail can be sent to individuals or groups simultaneously.

REMOTE LOGIN

Simple Telnet
Telnet is the Internet’s remote login protocol . It lets you sit at a keyboard connect to one computer
and log on to the remote computer across the network. The connection can be to a machine in
the same room , on the same  campus or distinct corner in the world . When you are connected,
it is as if your keyboard is connected directly to that  remote computer . You can access whatever
services the remote machine  provides to it’s local terminal .

Therefore, Telnet is a very basic but useful piece of software which allows you to make a
connection to a remote computer and log in to use it. There are two basic uses for Telnet,
logging into you own account from elsewhere, logging into general access services (such as
library catalogues).

FTP

FTP stands for  File Transfer Protocol and is the name of a program which allows you to
transfer files between computers on the Internet. There are two reasons why you might want to
do this. First, if you have access to computing facilities at another institution, you may want to
transfer your own files between that system and your system.

Second, the Internet is a vast repository of publicly available files of very conceivable type:
electronic scholarly journals; text files containing literary texts, bibliographies or episode guides
to cult TV series; graphics files of great works of art; fonts for various operating systems; large
amounts of free or shareware software. All of these can be downloaded to you local system.

Therefore, this protocols moves files from one computer to another. It does not matter,  where
the other computer is located or how they are connected ,or even whether or not they have the
same operating system. Provided they can “talk” the FTP protocol  and have access to Internet.
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WORLD WIDE WEB (WWW) (Also called Web or W3)

The World-Wide-Web (often referred to simply as the Web) is a multi-media hypertext system.
It works by displaying individual documents from anywhere on the Internet, which in turn may
provide links to other Internet documents, but it is considerably more sophisticated.

* It is capable of dealing not just with text files but with graphics, sound and video files,
which will be displayed or played on a Mac or PC with suitable hardware facilities and
appropriate support applications;

* It is capable of retrieving documents by a number of methods, so a Web browser can be
used, for example, to retrieve files from an anonymous ftp site, to access a gopher
server, or to long on to a library catalogue via a telnet connection;

* Instead of using menus, it allows the creator of a Web page to make any word or image
on the page into a “hot-spot” which will retrieve another document when it is selected
(so it resembles the Apple Hyper Card application or the Windows Help System).

* It is a huge collection of interconnected hypertext documents (web page) residing on
the various Web Servers.

* These documents contains links with each other & with other sites on the internet too
* With a Web browser, user can jump from one web page to another.
* These Web pages can be made available to user via URLs (Uniform Resource Locators)
* Web documents are made in HTML (hypertext language)
* WWW servers use HTTP (Hyper Text Transport Protocol) to deliver the called web

page to the user.

HTTP

Protocol used by Web browsers to respond to the requests to transfer the web documents to
the user, which the user makes via URLs. If this protocol is called, then we write “http://” before
the site address.

HTML

HTML is the native language for HTTP. It is  the format used for writing the hypertext web
documents. Items in the document can be text, images, or links to other HTML documents.
Hypertext documents have extension .htm or .html. A Web page may be a static or a dynamic
page which may consist of  the following:

* Plain (ASCII) text
* Formatted text
* Static graphics
* Animated graphics
* Sound
* Movies
* “links”
* Executable scripts
* Forms for passing data to applications
* “applets”
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A Web Page has to be coded in HTML (HyperText Markup Language)

* This is called the “source” document
* The WWW server transfers the whole “source” to client
* It is up to client browser software to render the document on the screen
* Consists of plain ASCII text, interspersed with markup “tags”
* The surfer only see the formatted text. The source of the web page is not displayed.

BROWSING

The remote login applications are fine if you know what you want, but ftp, for example, requires
all the files downloadable from a particular server to be physically present on a disk at the site,
leading to a substantial amount of duplication around the world. These problems have been
solved by systems called “browsers”.

A browser presents you with a document on which you can select certain items. However,
although these items may be located on your local system, or anywhere else on the Internet.
Once you select an item, the system retrieves that item from wherever it is located on the
Internet. You do not need to know where anything is actually located (though it is possible to
find out), because each document itself  “ knows” about the locations of linked documents.

USING THE MICROSOFT INTERNET EXPLORER FOR WEB-BROWSING

The Microsoft Internet Explorer

Internet Explorer is most commonly used Web-browser and is bundled along with Microsoft
Windows. With an Internet connection and Microsoft Internet Explorer, one can find and view
information about anything on the Web.

If Internet Explorer was set up on a computer by a local area network (LAN) administrator, or
by an Internet service provider’s (ISP) installation program, then one is ready to connect to the
Internet. Otherwise, the Internet Connection Wizard will guide you through establishing a
connection to the Internet. You will need the following information from your Internet Service
Provider or local area network administrator:

* Your account name and password, if you are using a dial-up link.
* Name of proxy server and port number if you are accessing through local area network.

Getting on to the Internet

To open Internet Explorer, click on Internet Explorer shortcut on the desktop or press
Start>Programs>Internet Explorer>Internet Explorer.

The Internet Explorer Window opens up as shown in the following figure.
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Establishing a Connection

If your Internet access is through Local Area Network and the Proxy Server and Port settings
are already done then the default home page if set, Intenet Explorer would open the default
home page.

Figure showing Internet Explorer

If you are using a dial-up connection, then you need to dial your Internet Service Provider
for getting on to the Internet. For Dial-up connections, the Internet Explorer shows working
Off-line or connect to the Internet options.
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The accompanying figure shows the dial-up connection and Dialing Progress Windows.

If the connection is established, the Modem at both the ends, performs the hand shaking of the
signals. If the required Protocols for transfer are established, the post terminal dial-up screen
opens up. The user is required to enter a valid user name and password at this prompt. Now
the user authentication is verified, and subsequently the Unix prompt of the server is shown.
Now the user is required to enter ppp as the protocol at this prompt. The user authentication
process is finished by pressing F7 or continue button on Post-Dial Terminal screen.

Figure showing Microsoft Internet Explorer
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VIEWING A WEB PAGE

There are several ways to go to a different Web page from the page currently being viewed. In
addition, one can search for Web pages if one do not have a particular address or link.

* In the Address bar, type the address of the Web page to view, or click the down arrow to
select it from the list, and then press ENTER.
To display the page in a new window, click File > New > Window .

* Click any link on the home page. A link can be a picture, a 3-D image, or colored text
(usually underlined).

* To go back to the previous page, click the Back button on the toolbar. 

To go more than one page back, click the small down arrow next to the button and then
click a Web page on the list.

To go forward to the next page (provided you have viewed it just previously), click the

Forward  button  on the toolbar. To go more than one page forward, click the

small down arrow next to the button and then click a Web page on the list.

Tips
* To go to a specific page click File > Open  and then type the address in the ‘Open’

dialog box.

* One can see whether an item on a page is a link by moving the mouse pointer over the
item. If the pointer changes to a hand, the item is a link.

THE ADDRESS BAR

An Address bar is a space to type and display the address for a Web page. When one types,
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the AutoComplete feature suggests a match based on Web sites that had been visited previously.

With the Address bar, one can also search for Web sites just by typing find , go , or ? followed
by a word that you’re searching for.

SAVING A WEB PAGE

1. On the File menu, click Save As .
2. Double-click the folder to save the page in.

3. In the File Name  box, type a name for the page, and then click Save.

Note : Internet Explorer prior to version 5.0 used to save only the text on a page, not the
graphics.

PRINTING A WEB PAGE

When printing a Web page, one can print the page as it appears on the screen, or the selected
parts of it, such as a frame.  In addition, one can specify to print additional information in the
headers and footers, such as the window title, page address, date, time, and page numbers.

SENDING WEB PAGE VIA E-MAIL

1. Open the page to be sent by mail.
2. Click File > Send > Page By Email  or Link By Email .
3. Type the address to send the Web page to, and then click the Send button on the toolbar.
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Note  : To include the Web page or link in an e-mail message, one must have an e-mail account.

REVISIT THE RECENTLY VIEWED WEB PAGES

1. On the toolbar, click the History  button. 

A list of folders appears, containing links for Web sites visited in previous days and
weeks.

2. Click a folder or page to display the Web page.

Tips
* One can change the number of days that pages are saved in the History list. The more

days you specify, the more disk space is used on your computer to save that information.
* One can hide the Explorer bar by clicking the History  button again.

ADDING A WEB PAGE TO FAVORITES

1. Go to the page to add to the collection of favorite pages.
2. On the Favorites menu, click Add to Favorites .
3. Type a new name for the page if required.

Tips

* Click the Favorites  button  on the toolbar to open one of a favourite page, and

then click the page to open.
* To keep track of favorite pages, organize them into folders. Click the Create In button in

the Add to Favorites dialog box.
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SEARCHING THE WEB

Information is available on the Web in a variety of ways. On clicking the Search  button on the
toolbar, the Explorer bar appears at the left of the window. It provides access to a number of
search services that offer different kinds of searching capabilities.

To find information extra quickly, use the AutoSearch feature by typing go , find , or ? followed
by a word or phrase, right in the Address bar. Internet Explorer immediately starts a search
using its predetermined search service.

One can also use ‘search engines’ like Yahoo, Lycos, Altavista, Metacrawler etc. which provides
key-word searching facilities.

SEARCHING TEXT ON A WEB PAGE

To search for a particular word or phrase on a particular web-page click Edit>Find(on this
page). On the Find dialog box, type the text to find and then click ‘Find Next’. If found, the text
will be highlighted.
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SEARCHING THE INTERNET

1. On the toolbar, click the Search  button. 

2. In the Explorer bar that appears, type the word or phrase to look for, and then click
Search .

3. In the list of search results, click a link to display the Web page in the right side of the
browser window.
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OFFLINE BROWSING

With “offline browsing,” one can view Web pages without being connected to the Internet. This
is handy if one don’t have access to the Web when browsing the Web pages, i.e. while using
the laptop computer at a location that does not provide any network or modem access or at
home and not using the telephone line.

BROWSING THE WEB OFFLINE

Click File > Work Offline .

Note :  On choosing ‘work offline’, Internet Explorer will always start in offline mode until the
‘work offline’ option is selected again.

INTERNET GLOSSARY

CGI (Common Gateway Interface)
A standard that allows Web servers to run External Applications such as search engines.
Firewall
Hardware or software the restricts traffic to a private network from an unsecured network.
FTP (File Transfer Protocol)
An Internet protocol that allows a user on one host to transfer files to and from another host
over a network.
Home Page
The first page of a Web site or of a logical group of HTML documents.
HTML (Hyper Text Markup Language)
The language with which World Wide Web documents are formatted. It defines fonts, graphics,
hypertext links, and other details. HTML is an implementation of SGML.
HTTP (Hyper Text Transfer Protocol)
The protocol that negotiates document delivery to a Web browser from a Web server.
Hypertext
A way of presenting information in which there are links from one document to another. In a
Web document, the link is a URL, pointing to another Web page or other resource.
Internet
A private network that uses internet software and standards.
A web server programming interface for back-end applications developed by Microsoft and
process Software Corp.
JAVA
An object-oriented language, developed by Sun Microsystems, for writing distributed Web
applications.
Perl
An interpreted scripting language, typically used in writing CGI scripts.
SGML (Standard Generalized Markup Language)
A standard for defining and managing the structure and format of electronic documents.
SQL (Structured Query Language)
A standard language for requesting information from a relational database.
TCP/IP (Transmission Control Protocol/Internet Protocol)
The collection of transport and application protocols used to communicate on the internet and
other networks.


